как составить программу подсчета количеству делений введённого числа на 12 пока оно не станет меньше 10

Pascal:
var count:integer;
     n:real; 
begin
  write (N = );
  readln(n);
  count:=0;
  while n>=10 do
    begin
      n:=n/12;
      inc(count);
    end;
  write (Kol-vo: ,count);
  readln;
end.

C++:
#include
using namespace std;

int main()
{
   float n;
   int count = 0;
   cout <<"N = ";
   cin >>n;
   while (n>=10)
   {
      n/=12;
      ++count; 
   }
  cout <<"Kol-vo: " <  return 0;
}

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку