Помогите пожалуйста!!!! Не могу написать программу на языке паскаль. Даны три целых двузначных числа. Из наибольшего из них вычесть наименьшее и сравнить результат с оставшимся числом. Если полученное число будет больше вывести YES в противном случае NO.

Var
  a,b,c,max,mid,min,t:integer;
begin
  Writeln(Введите через пробел три целых двухзначных числа);
  Readln(a,b,c);
  if a>b then begin max:=a; min:=b end
  else begin max:=b; min:=a end;
  if max  else mid:=c;
  if min>mid then begin t:=mid; mid:=min; min:=t end;
  if (max-min)>mid then Writeln(YES)
  else Writeln(NO)
end.

Тестовое решение:
Введите через пробел три целых двухзначных числа
37 93 74
NO



Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку