Напишите программу , которая переводит десятичные числа в эквиваленты из соответствующих систем счисления по основанию b, 10 > b <= 36.

Var i,k,j,n,ost,p:integer;   
x,s:string;
begin 
  read(s); 
  n:=strtoint(s); 
  for j:=11 to 36 do   
  begin     
    x:=;     
    p:=n;     
    k:=0;     
    while p<>0 do       
    begin         
      ost:=p - (p div j)*j;         
      p:=p div j;         
      k:=k+1;         
      if (ost >9) and (ost <=36) then
        x:=chr(ost+55)+x         
      else
        x:=inttostr(ost)+x;       
    end;;     
  writeln(x,  ,j, ss);   
  end;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку