Факториалом числа 5 (обозначается 5!) называется значение следующего выражения: f=1*2*3*4*5. Составьте программу, которая запросив у пользователя целое число n, вычислит значение факториала числа. (Линейное программирование, цикл с параметром)
Var
i,n,p:longint;
begin
Write(Введите целое число n -> ); Readln(n);
p:=1;
for i:=2 to n do p:=p*i;
Writeln(n!=,p)
end.
Тестовое решение:
Введите целое число n -> 5
n!=120
Оцени ответ
