Составить программу и блок - схему для сравнения роста двух девочек. Напечатайте имя той, которая выше.
Var
h1,h2:integer;
n1,n2:string;
begin
Write(Введите имя первой девочки: ); Readln(n1);
Write(Введите рост первой девочки: ); Readln(h1);
Write(Введите имя второй девочки: ); Readln(n2);
Write(Введите рост второй девочки: ); Readln(h2);
if h1>h2 then Writeln(n1, выше, чем ,n2)
else if h2>h1 then Writeln(n2, выше, чем ,n1)
else Writeln(n1, и ,n2, одного роста)
end.
Тестовое решение:
Введите имя первой девочки: Наташа
Введите рост первой девочки: 163
Введите имя второй девочки: Даша
Введите рост второй девочки: 167
Даша выше, чем Наташа
Блок-схема дана во вложении. Блоки ввода вывода упрощены в связи с невозможностью (и ненужностью) точно отобразить вид ввода и вывода.
Оцени ответ
