Помогите с программированием пожалуйста ( Pascal ).
Дан массив случайных целых чисел D из промежутка [0;10], состоящий из 10 элементов. Составить программу вычисления суммы трех элементов. В качестве подпрограммы оформить вычисление суммы трех последовательно расположенных элементов массива с номерами от k до m: D[1], D[2], D[3], D[3], D[4], D[5], D[4], D[5],D[6].

123456789101112131415161718192021222324252627282930313233343536uses crt;const n=10;var a:array[1..n] of integer;    i,k,k0:integer;    s:real;begin clrscr;  writeln(Массив :);   for i:=1 to n do    begin     write(i, = );      read(a[i]);    end;    k:=1;  for i:=1 to n do   if a[i]<0 then    begin     s:=s+a[i];     inc(k);    end   else     begin      if a[i]>0 then      inc(k0);     end;  s:=s/k;writeln;  if (k=1) and (k0=0) then   writeln(Положительных или отрицательных элементов в массиве нет,среднее ариф-ское = 0)  else   writeln(Среднее ариф-ского отрицательных элементов массива =,s:0:2);   readkey;end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку