Напишите программу, которая по заданному натуральному n печатает первые n чисел последовательности 1, 2, 4, 8, 16, 32.
В первой строке содержится n (1 ≤ n ≤ 50) – количество чисел.
Вывести первые n чисел геометрической прогрессии со знаменателем 2 и первым членом 1.
с++

#include

int main()
{
int n, i;

scanf("%d", &n);

if (n>=1&&n<=50)
{

for (i=1; i<=n;i*=2){

printf("%d ", i);
}
}
return 0;
}


Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку