Автомат принимает трёхзначное число, вычисляет сумму двух старших разрядов (сотен и десятков), а также сумму двух младших разрядов( десятков и единиц). Затем эти суммы выводятся на экран в порядке убывания (без пробелов). Напишите программу, которая моделирует работа автомата.
Program zadanie;
Var a,b,s1,s2,n:integer;
Begin
Writeln(Введите 3-х значное целое число);
Readln(n);
a:=n div 100;
b:=(n div 10) mod 10;
s1:=a+b;
a:=(n mod 100) mod 10;
s2:=a+b;
Writeln(s1,s2);
End.
Оцени ответ
