Составить программу для нахождения площади ромба по стороне а и острому углу f (угол предварительно переведите в радианы t = f · 3,14 : 180) по формуле S = a 2 sin t

Var
  a, f, t, S: real;

begin
  Write(Введите длину стороны ромба: ); Readln(a);
  Write(Введите величину острого угла ромба в градусах: ); Readln(f);
  t := f * pi / 180;
  S := sqr(a) * sin(t);
  Writeln(Площадь ромба равна , S, кв.ед.)
end.

Тестовое решение:
Введите длину стороны ромба: 14.3
Введите величину острого угла ромба в градусах: 58.7
Площадь ромба равна 174.728286173858 кв.ед.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку