Пожалуйста срочно! составить программу нахождения корней квадратного уравнения если a=3 b=34 c=4b и выводящую ответ на экран

Мой код на Java прикреплен, 427 строк где-то (907 в оригинале)
вот код на паскале для твоей задачи
var a,b,c,d:integer;
x1,x2:real;
begin
readln(a,b,c);
d:=(b*b) - (4*a*c); writeln(d);
if d < 0 then writeln(корней нет);
if d = 0 then begin writeln(один корень); x1:=-b/(2*a); writeln(x1:0:3); end;
if d > 0 then begin writeln(два корня); x1:=(-b-sqrt(d))/(2*a); x2:=(-b+sqrt(d))/(2*a); writeln(x1:0:3,x2:0:3); end;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку