Напишите программу, запрашивающую ввод с клавиатуры трех строковых величин – взаимосвязанные прилагательное, существительное и глагол, а затем выводит на экран все возможные варианты сочетаний этих слов в предложении. Слова вводит пользователь любые!!! См. пример в таблице
Входные данные Выходные данные
ОСЕННИЕ осенние листья опадают
ЛИСТЬЯ осенние опадают листья
ОПАДАЮТ листья осенние опадают
листья опадают осенние
опадают осенние листья
опадают листья осенние
Var
a,b,c:string;
begin
write(Введите прилагательное );
readln(a);
write(Введите существительное );
readln(b);
write(Введите глагол );
readln(c);
begin
writeln(a, ,b, ,c);
writeln(a, ,c, ,b);
writeln(b, ,a, ,c);
writeln(b, ,c, ,a);
writeln(c, ,a, ,b);
writeln(c, ,b, ,a);
end;
end.
Оцени ответ
