Напишите программу на языке Паскаль, распознающую по длинам сторон среди всех треугольников прямоугольный. Если они прямоугольные, то должно выводится сообщение Это прямоугольный треугольник.
Var a,b,c:real;
begin
read(a, b, c);
if ((a=sqrt(sqr(b)+sqr(c)))or(b=sqrt(sqr(a)+sqr(c)))or(c=sqrt(sqr(a)+sqr(b))))then
write(Это прямоугольный треугольник)
else
write(Это не прямоугольный треугольник)
end.
Оцени ответ
