Алгоритм евклида для вычисления нод двух натуральных чисел формируется так нужно заменять большее число на разность большего и меньшего до тех пор пока одно из них не станет равно нулю тогда второе и есть нод напишите программу которая реализует этот алгоритм какой цикл тут нужно использовать
Var
a,b:integer;
begin
Write(Введите два натуральных числа ); Readln(a,b);
while a<>b do
if a > b then a := a - b
else b := b - a;
Writeln(НОД=,a)
end.
Тестовое решение:
Введите два натуральных числа 28 16
НОД=4
Оцени ответ
