Ребята помогите, очень срочно!
Тело брошено с начальной скоростью v0 под углом альфа к горизонту. Составьте программу, выводящую в столбец время t (в секундах), значения времени от 0 до 10 с шагом 0,5 ; во второй и третий столбцы - координаты тела х(t) и у(t). Зависимость координат от времени описывается формулами:
x(t) = v0 * t * cos (a*3,14 / 180)
y(t) = v0 * t * sin a*3,14/180 - g*t*t /2
g = 9,81 - ускорение свободного падения
Const
pi = 3.14;
g = 9.81;
var
v0, alpha, x, y, t: single;
begin
Write(Введите начальную скорость и угол: );
Readln(v0, alpha);
Writeln( t x y);
t := 0;
while t <= 10 do
begin
x := v0 * t * cos(alpha * pi / 180);
y := v0 * t * sin(alpha * pi / 180) - g * t * t / 2;
Writeln(t:4:1, x:11:3, y:13:3);
t := t + 0.5
end
end.
Тестовое решение:
Введите начальную скорость и угол: 30 60
t x y
0.0 0.000 0.000
0.5 7.507 11.760
1.0 15.014 21.068
1.5 22.521 27.923
2.0 30.028 32.326
2.5 37.534 34.276
3.0 45.041 33.773
3.5 52.548 30.819
4.0 60.055 25.411
4.5 67.562 17.551
5.0 75.069 7.239
5.5 82.576 -5.526
6.0 90.083 -20.743
6.5 97.590 -38.413
7.0 105.097 -58.535
7.5 112.603 -81.110
8.0 120.110 -106.138
8.5 127.617 -133.617
9.0 135.124 -163.550
9.5 142.631 -195.935
10.0 150.138 -230.772
Отрицательные значения y в данном случае показывают, что тело как бы продолжает падать ниже первоначального уровня, что возможно только если с горы кидать что-то в пропасть)))
