Составить программу, которая находит минимальное натуральное число х, такое, что остаток от деления х на 10 равен 9, остаток от деления х на 9 равен 8, остаток от деления х на 8 равен 7, … остаток от деления х на 2 равен 1.

Var i: integer;
begin
for i := 1 to 9000 dobegin  if ( i mod 10 = 9 ) AND ( i mod 9 = 8 ) AND ( i mod 8 = 7 ) AND ( i mod 7 = 6 ) AND ( i mod 6 = 5 ) AND ( i mod 5 = 4 ) AND ( i mod 4 = 3 ) AND ( i mod 3 = 2 ) AND ( i mod 2 = 1 ) then
begin writeln(x = , i);
break;
end;
end;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку