Напишите программу, которая выводит на экран все цифры числа начиная с первой. (на Паскале)

Var    str, i, m:integer;
n: string;
a: array[1..10] of integer;
begin
write(Введите число: );
readln(str);
if str < 0 then str := -str; // удаляем знак числа
n := IntToStr(str); // преобразуем число в массив
m := length(n); // считаем элементы массива
for i := 1 to m do writeln(n[i]); // выводим элементы (цифры) числа
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку