Помогите выполнить это задание по информатике:
Составить программу на языке Паскаль для решения следующей задачи: задать одномерный массив случайным образом, элементы которого принадлежат промежутку [-30;20] и найти наименьший элемент среди положительных элементов (учесть вариант, когда в массиве может не оказаться положительных элементов).
Прошу учесть правильность написания самой программы (Чтобы можно было вставить в паскаль и не исправлять чужие ошибки.(Я ещё в своих не разбираюсь))

Const
    n = 3;
var
  i,b:integer;
  a:array[1..n] of integer;
begin
  b:=21;
  for i:=1 to n do
   begin
     a[i]:=random(51)-30;
     if (a[i]>0) and (a[i]   end;
  writeln(Полученный массив:);
  for i:=1 to n do
   write(a[:4,i,]=,a[i]);
  writeln;
 if b<21 then write(Наименьший элемент = ,b) else write(Нет положительных элементов)
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку