Используя сначала цикл с условием, а затем - цикл с переменной, напишите программу, которая выводит на экран четные степени числа 2 от
до
в порядке убывания
Четные степени числа 2 - это все равно что целые степени числа 4 от до
.
Программы на Pascal:
program first;
var i:integer;
begin
i:=1024;
while i>1 do begin
writeln(i);
i:=i div 4;
end;
end.
program second;
var i,pow:integer;
begin
i:=1024;
for pow:=5 downto 1 do begin
writeln(i);
i:=i div 4;
end;
end.
Оцени ответ
