Двумерный массив А (4;4) найдите максимальный элемент

Const N = 4;
var  a: array[1..N,1..N] of integer;
i,j,k,z: integer;
begin  for i := 1 to N do  begin
for j := 1 to N do
begin
a[i,j]:=random(10);
write(a[i,j]:5);
end;
writeln();
end;
writeln();
k:=1;
z:=1;
for i:=1 to N do for j:=1 to N do if a[i,j] > a[k,z] then
begin
k:=i;
z:=j;
end;
writeln(Максимальный элемент: ,a[ k, z ]);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку