Напишите программу, которая получает два целых числа и находит их произведение, не используя операцию умножения. Учтите, что числа могут быть отрицательными. Через цикл WHILE!!!! (c++)
program prog1;
var
x,y,a,z:integer;
begin
write(Введите два числа:);
readln(x,y);
z:=1;a:=0;
while (z<=y) or (z<=x) do
begin
if y>0 then
begin
z:=z+1;
a:=a+x;
end;
if y<0 then
begin
z:=z+1;
a:=a+y;
end;
end;
writeln(a);
readln;
end.
Считает теперь, если одно отрицательное число.
Оцени ответ
