Напишите программу для решения следующей задачи.
Ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали дневную температуру. Найдите среднюю температуру за время наблюдения. Если количество дней, когда температура поднималась выше нуля градусов, не менее 5, выведите YES, иначе выведите NO.
Программа получает на вход количество дней, в течение которых проводилось наблюдение N (1 ≤ N ≤ 31), затем для каждого дня вводится температура.

Var a:array[1..31]of integer;
N,s,i,k:integer;
begin
s:=0;
k:=0;
writeln(Введите кол-во дней);
readln(N);
for i:=1 to N do
begin
readln(a[i]);
s:=s+a[i];
if a[i]>0 then k:=k+1;
end;
s:=s/N;
writeln(Средняя температура,s);
if k>=5 then writeln(YES) else writeln(NO);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку