Составьте программу, позволяющую определить, являются ли числа A,B,C, пифагоровыми тройками.Указанные числа A,B,C, являются пифагоровыми тройками, если квадрат одного из чисел равен сумме квадратов двух других.
Program pifThi;
var
a,b,c:integer;
begin
readln(a,b,c);
if (sqr(a)=sqr(c)+sqr(b)) or
(sqr(b)=sqr(a)+sqr(c)) or
(sqr(c)=sqr(a)+sqr(b)) then write(Yes!)
else write(No!); readln;
end.
Оцени ответ
