Помогите пожалуйста!!!!!! Написать программу на языке с#:Дана точка на плоскости с координатами (х, у). Составить программу, которая выдает одно из сообщений «Да», «Нет», «На границе» в зависимости от того, лежит ли точка внутри заштрихованной области, вне заштрихованной области или на ее границе.
#include
using namespace std;
int main()
{
float x,y,rxy;
cin>>x>>y;
rxy=x*x+y*y;
if ((rxy>100) || (rxy<25)) cout<<"Нет"<
}
C# вот код:
using System;
class Program
{
static void Main()
{
double x=Convert.ToDouble(Console.ReadLine());
double y=Convert.ToDouble(Console.ReadLine());
double rxy=x*x+y*y;
if ((rxy>100) | (rxy<25)) Console.WriteLine("Нет");
else if ((rxy==100) | (rxy==25)) Console.WriteLine("На границе");
else Console.WriteLine("Да");
Console.ReadLine();
}
}
Оцени ответ
