Имеется информация об адресах учеников одного класса в виде: фамилия, имя, город, улица, № дома. Написать программу, позволяющую вывести список учеников, проживающих в городе
Type
Uch=record
fam:string[20];
nam:string[20];
city:string[20];
street:string[20];
numb:string[8]
end;
var
f:file of Uch;
bUch:Uch; { буфер }
c:string;
begin
Assign(f,Uch.txt);
Reset(f);
Write(Введите название города: ); Readln(c);
while not Eof(f) do begin
Read(f,bUch);
if c=Trim(bUch.city) then
With bUch do Writeln(fam, ,nam, ,street, ,numb)
end;
Close(f)
end.
Оцени ответ
