Написать программу на паскале, где необходимо реализовать расчет значения Y в зависимости от полученного X.
Составим уравнение это кусочной функции.
По непонятной мне причине, местный редактор формул внутри себя корректно отображает формулу, а при попытке сохранения её в ответ все рушится. Посему формула отправлена во вложение.
var
x, y: real;
begin
Write(Введите х: );Readln(x);
if x <= -9 then y := 0
else if x < -6 then y := -sqrt(9 - sqr(x + 6))
else if x <= -3 then y := x + 3
else if x < 0 then y := sqrt(9 - sqr(x))
else if x <= 3 then y := 3 - x
else if x < 9 then y := (x - 3) / 2
else y := 3;
Writeln(y=, y)
end.
Оцени ответ
