Начав тренировку лыжник в 1 день пробежал 10 км. Каждый след. день он увеличивал длину пробега на 10% от пробега предыдущего дня. Определить: а)в какойдень он пробежал больше 20 км. б) в какой день суммарный пробег за все дни превысит 100 км? Задача по информатике, надо составить программу в pascal abc. Помогите решить в программе Pascal, с помощью whileребят отзовитесь от этого зависит моя оценка, очень прошу


var
s:real;
flag,d,m:integer;
begin     
      s:=10; d:=1;
          while s<=100 do             
               begin                 
                  writeln(d: ,d,   s: ,s);  {эта строка не обязательна, выводит на экран ежедневный пробег, как бы для контроля}         
                      s:=s+s*0.1;                   
                      d:=d+1;                       
                            if s<20 then                           
                                  flag:=d;             
                end;
      writeln(> 20 km :, flag+1,    day);
      writeln(>100 km : ,d);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку