
Гарри Поттер узнал, в Хогвартсе номера комнат преподавателей делятся без остатка на все свои цифры, в остальных же комнатах живут ученики. Помогите Гарри определить по известному номеру комнаты N (1 Формат входных данных:
Исходный файл содержит одно число N (1 Формат выходных данных:
В выходной файл вывести, букву «T», если в комнате живет учитель (число N делятся без остатка на все свои цифры кроме нуля) или «P» если ученик (число N не делятся без остатка хотя бы на одну из цифр).
Пример:
INPUT.TXT OUTPUT.TXT
754 P
12222 T
Комментарии: если одна из цифр числа ноль деление на неё не учитывать.

Var
c,n,k:int64;
t:boolean;
begin
read(n);
c:=n;
t:=true;
while (n<>0) and (t) do
begin k:=n mod 10; if k<>0 then
if c mod k<>0 then t:=false;
n:=n div 10;
end;
if t=true then writeln(T) else writeln(P);
end.
Оцени ответ