Ряд чисел Фибоначчи задается следующим образом: первые два числа равны 1 ( F 1 = F 2 = 1 ), а каждое следующее равно сумму двух предыдущих: F n = F n - 1
+ F n - 2 . Напишите программу, которая вводит натуральное число N и выводит на экран первые N числа Фибаначчи
1 var a, b, c, n, i: integer;
2
3 begin
4 writeln(Vvedite N);
5 readln(n);
6 a :=1; b :=1;
7 for i := 3 to n do begin
8 c := a + b;
9 a := b;
10 b :=c;
11 end;
12 writeln(c);
13 end.
Оцени ответ
