Паскаль
Напишите программу, которая заполняет квадратную матрицу случайными числами в
интервале [10,99], и находит максимальный и минимальный элементы в матрице и их
индексы

Var a[1..10, 1..10] of integer;
i, j, max, min, imin, imax, jmin, jmax:integer;
begin
imax:=0; imin:=0; jmax:=0; jmin:=0;
max:=-maxint;
min:=maxint;
for i:=1 to 10 do
for j:=1 to 10 do
begin
a[i,j]:=random(80)-10;
write(a[i,j], );
if a[i,j]if a[i,j]>max then begin man:=a[i,j]; iman:=i; jman:=j; end;
end;
writeln;
writeln(Максимальный элемент:,max);
writeln(Его индекс,imax, ,jmax);
writeln(Минимальный элемент:,mix);
writeln(Его индекс,imix, ,jmix)
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку