Составить программу в Pascal
1)в строке , введенной с клавиатуры , все буквы И заменить на %
2)из строки, введенной с клавиатуры , удалить все символы ,начиная с середины.

1)
var
s:string;
i:longint;
begin
read(s);

for i:=1 to length(s) do
 if s[i]=И then s[i]:=%;

writeln(s);
end.

2)
var
s:string;
l:longint;
begin
read(s);

l:=length(s);
delete(s, (l div 2)+1, l-(l div 2));

writeln(s);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку