Составьте программу,по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел
(массив не использовать).Сделайте три варианта программы,используя операторы While,Repeat ,For.
Программа может выглядеть так:
uses Crt;
const n=10;
var a, i, Sum: integer;
Sred: real;
begin
ClrScr;
Sum:=0;
i:=1;
While i<=10 do
begin
Write (a = );
ReadLn(a);
Sum:=Sum+a;
i:=i+1;
end;
Sred:=Sum/n;
Writeln(Sred = , Sred:6:2);
WriteLn;
Sum:=0;
i:=1;
repeat
Write (a = );
ReadLn(a);
Sum:=Sum+a;
i:=i+1;
until i>n;
Sred:=Sum/n;
Writeln(Sred = , Sred:6:2);
WriteLn;
Sum:=0;
for i:=1 to n do
begin
Write (a = );
ReadLn(a);
Sum:=Sum+a;
end;
Sred:=Sum/n;
Writeln(Sred = , Sred:6:2);
ReadLn;
end.
Оцени ответ
