Срочно! создать программу!
тема "организация подпрограмм через функцию"
задача
дан параллепипед с измерениями а,b, c. Составить программу для нахождения площади полной поверхности, используя подпрограмму нахождения площади прямоугольника.

Вычисление производим по формуле
S=2(ab+ac+bc)=2(Sp_{(a,b)}+Sp_{(a,c)}+Sp_{(b,c)});  Sp_{(x,y)}=xcdot y

function Sp(x,y:real):real;
begin
  Sp:=x*y
end;

var
  a,b,c,S:real;
begin
  Write(Введите размеры сторон a,b,c: );
  Read(a,b,c);
  S:=2*(Sp(a,b)+Sp(a,c)+Sp(b,c));
  Writeln(Площадь поверхности равна ,S)
end.

Тестовое решение:
Введите размеры сторон a,b,c: 2.5 3.15 4
Площадь поверхности равна 60.95

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку