Составить программу для вычисления корня нелинейного уравнения по методу касательных х^2-cos(x^2)=6
Для метода касательных (он же - метод Ньютона) надо задать начальное приближение и получить выражение для производной функции.
Рекуррентная формула в методе Ньютона имеет следующий вид:
Для нашей конкретной задачи можно записать:
А еще надо задать погрешность решения, которую определим так:
function f(x:real):real;
begin
f:=sqr(x)-cos(sqr(x))-6
end;
function fn1(x:real):real;
begin
fn1:=x-(sqr(x)-cos(sqr(x))-6)/(2*x*(1+sin(sqr(x))))
end;
var
xn,xn1,y,eps:real;
begin
Writeln(Введите начальное приближение для корня: );
Read(xn);
Writeln(Введите значение погрешности для решения: );
Read(eps);
xn1:=xn; y:=f(xn);
while abs(y)>eps do
begin xn1:=fn1(xn); y:=f(xn1); xn:=xn1 end;
Writeln(x=,xn1, f(x)=,y)
end.
Тестовое решение:
Введите начальное приближение для корня:
-3
Введите значение погрешности для решения:
0.00001
x=-2.61645602631473 f(x)=1.28691349221555E-06
