Задача: У вас есть доллары. Вы хотите обменять их на рубли. Есть информация стоимости купли-продажи в банках города. В городе N банков. Составьте программу, определяющую, какой банк выбрать, чтобы обменять доллары на рубли наиболее выгодно.
Язык программирования Паскаль ABC
Program p1;
const n=5;
var i:integer;
kurs: array[1..n] of real;
summa,r,bank: real;
begin
writeln(Введите сумму: );
read(summa);
for i:=1 to n do begin
writeln(Введите курс в ,i, банке: );
read(kurs[i]);
end;
r:=0;
for i:=1 to n do begin
if (kurs[i]*summa)>r then
begin
r:=kurs[i]*summa;
bank:=i;
end;
end;
writeln(Выгодно в банке №: ,bank);
end.
Оцени ответ
