Мой богатый дядюшка подарил мне один доллар на мой первый день рождения. В каждый следующий день рождения он удваивал свой прошлогодний подарок, прибавлял к нему столько долларов, сколько лет мне исполнялось, и полученную сумму дарил мне. Напишите программу, подсчитывающую общую сумму всех денег, подаренных к -му дню рождения.
Формат входных данных
На вход программе подается единственное число .
Это в паскале
Var
i,s,k,n:integer;
begin
readln(n);
s:=0;k:=0;
for i:=1 to n do
begin
s:=2*s+i;
k:=k+s;
end;
write(Дядюшка подарил ,k, долларов.);
end.
Оцени ответ
