Напишите программу, которая в последовательности натуральных чисел определяет максимальное четное число. Программа получает на вход целые числа, количество введенных данных неизвестно, последовательность чисел заканчивается числом 0. На Паскале
var a,max:integer;
begin
max:=0;
a:=0;
read(a);
while a<>0 do
begin
if (a mod 2=0) and (a>=max) then max:=a;
read(a);
end;
write(max);
end.
Оцени ответ
